No puedes actualizar porque WordPress 6.5.2 necesita una versión de MySQL superior a la 5.5.5. Actualmente tienes la versión 5.1.73.